Impact has detected that you are activating this licence on a virtual machine (HyperV)

Symptoms

During Impact start-up or first activation, you receive the message on the Impact Licence Activation dialog that states: 'Impact has detected that you are activating this licence on a virtual machine (HyperV). A licence must be re-activated everytime you restart Impact and requires access to the internet'



This same activation dialog and message may reappear on each Impact start-up.


Cause

The Nalpeiron-based software licensing features are intentionally restricted on virtual machines, and will need to be reactivated with each use of Impact.  Certain Windows virtualisation and security features can also cause Nalpeiron to detect an otherwise physical machine as acting in this way.


Solution

If you are trying to run Impact on a virtual machine, and do not wish to manually activate Impact with every use you have several options:

  1. Switch to Arden Licence Server, which also provides the added flexibility of sharing licences across multiple workstations in the same network.
  2. Configure Impact to automatically activate when Impact is started:
    • Having manually activated Impact where machine virtualisation was detected, a checkbox will appear with the prompt 'Automatically attempt to activate this licence when Impact restarts'.
    • This is also configurable via the registry options under Computer\HKEY_CURRENT_USER\SOFTWARE\Arden Software Ltd\Impact\XX\Installs, 'LicenceAttemptActivation' (value: 1), and will utilise the licence code present within 'LicenceActivationCode0', i.e. the last activated code.
  3. If you are not using a virtual machine, but have some Windows features enabled that are causing the Nalpeiron licensing features to treat your workstation as such, you may consider disabling the relevant options mentioned here: Windows Virtualisation Options.


Still Not Working

If the above solution has not resolved your problem, you may have found another cause of this error. Please create a support ticket and describe the problem you're having in as many details as you can.


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