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Complete Circles may be split into segments when imported into ZCC (PDF format)

Complete circles (ie single arc-type entities with a 360º sweep), contained in an Impact-generated PDF file, may be imported into the ZCC suite as individual arc segments.


Symptoms

When physically output to the Zund plotter, the circles may be cut/drawn as a series of arcs, as opposed to a single entity.


Within the ZCC suite itself, several of the viewing options will show a series of entities, as opposed to a single entity:



Zund Cut-Centre Context Menu



Zund Cut-Centre View>Order

Zund Cut-Centre View>Open Contours


Cause

The PDF format has concepts of paths & strokes. 


A path is made up of a series of points called “anchor points” and line segments between these points (the line segments can be straight or curved). 


A stroke is the visible outline of an object or a path.


If the supplied PDF file does not contain 'paths', the segments will be interpreted as individual entities.


If the supplied PDF contains does contain 'paths', the segments can be treated as a single, continuous entity.


Impact supports the output of both 'compound' and 'simple' PDF 'paths'.


Effectively a 'simple' PDF 'path' can be regarded as a sequence of end-to-end entities, which share the same palette.


A 'compound' PDF 'path' can be regarded as a collection of entities, which are not 'end-to-end', but which share the same palette (similar to a selection made by Impact's 'Select by Palette' tool).


The ZCC software (tested against ZCC 3.1.7) supports 'simple' PDF paths.



Solution

There are 2 approaches to solving this issue:


Option 1 - Within the ZCC Suite

  1. Open the ZCC Cut Manager application.
  2. Click the Hotfolder menu.
  3. Open the relevant Hotfolder setting.
  4. Click the Optimization tab.
  5. Enable the "Chain open contours within" option and set an appropriate value:

ZCC Hot Folder Settings > Optimization tab


6. Check the ZCC Help document for further details - typically this can be found at C:\Program Files\Zund Systemtechnik\Zund Cut Center\docs.

7. Re-start the ZCC Cut Manager application and confirm that the above changes have been saved.

8. Send a new test file into the ZCC Cut Queue for processing.

9. Check the View options shown above and confirm that a single path is displayed (with no open contours):

Zund Cut-Centre View>Order


Option 2 - Within Impact

  1. Open the export filter which you're using to generate the PDF file (Options>Master Tool Settings>General Tools>Import Export Settings - note that the setting may be contained within a sub-folder).
  2. Expand the Export node.
  3. Click the Adobe PDF node.
  4. Enable the "Create a path for each exported palette" option.
  5. Pick the "Simple Paths" option:                                                    Impact Import/Export Settings - Adobe PDF Export Branch
  6. Click OK.
  7. Generate a new test file and send this to the ZCC Cut Queue for processing.
  8. Check the View options as above and confirm that a single path is displayed (again, with no open contours):

Zund Cut-Centre View>Order


Further Examples

Consider the following FEFCO 0427 profile (with circular cut-outs in the lid). Note the tool up/down distances (and occurrences) and the total processing time:



Exporting the same geometry, but making use of 'simple' PDF 'paths' (in Impact's PDF export filter) generates the following:



Notice the significant reduction in tool up/down occurrences (& tool-up distances), and a shorter processing time.


Deploying the ZCC 'Close open contours' solution generates the following:


Compare this report to the Impact 'simple paths' solution - an identical number of tool up/down occurrences, a slightly shorter Crease tool 'up' distance, but a longer Thru-cut tool 'up' distance.


That said, the total processing time is identical (1m 20s).


Still Not Working

If the above solution has not resolved your problem, you may have found another cause of this error. Please create a support ticket and describe the problem you're having in as much details as you can. You may be asked to provide the following information so to expedite a solution, it would be useful if you could add the appropriate information to your ticket.

  • The date and time the problem occurred and the user name or names that has experienced the problem.
  • Screenshots showing the problem including the entire site and address bar. Please do not zoom in on an area as important information can be easily missed.
  • A screen recording of you reproducing the problem.





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