Impact is failing during import or export, giving the error 'No settings with the specified file format could be found'.
Symptoms
A warning message stating 'No settings with the specified file format could be found' is displayed either when attempting to import or export a drawing or 3D model, via one of the following 2D or 3D tools:
- File>Import>Import
- File>Import>Import 3D
- File>Export>Export
- File>Export>Export 3D
No import or export settings are displayed at the subsequent dialogs, and as a result, you are unable to import or export the 2D drawing or 3D model.
2D example – Export dialog when exporting to the 'LVS format'
3D example - Export 3D Scene dialog when exporting to the 'Wavefront (*.obj) format'
3D example - Export 3D dialog when exporting to the Wavefront (*.obj) format
3D example - Export File dialog when exporting to the Wavefront (*.obj) format
Cause
This error message will be displayed when there are no configured Master Tool Settings (in the current database) enabled to handle the required file format. This is applicable to both 2D & 3D formats.
Solution
The solution is identical for both import and export tools, so here we will use only export as a working example.
To resolve this issue, you can either edit an existing export setting (to enable the file format in question) or create a new export setting and enable the format in question.
Firstly, access the Master Tool Settings (via Options>Master Tool Settings):
Refer to the relevant next steps for either a 3D or 2D file format related solution:
3D File Format
If the message was displayed when using the File>Export>Export 3D tool, expand the 3D folder and click (or expand) the '3D Import / Export Settings' folder.
Look for a suitable existing 3D Import / Export setting you wish to modify. In this example, we will refer to '<Default 3D Export>'. Simply right-click on the setting and pick Change from the context menu.
Enable the missing file format in question (in this example, the Wavefront (*.obj) format), then click OK to update the setting.
Remember to consult the wider documentation for any format-specific import / export options you may need to configure.
If you don't have a suitable existing setting, right-click on the whitespace and pick Add from the context menu:
Name the setting appropriately, enable the file format in question, then click OK to add the new setting.
Re-try the 3D export and this time, you should have an available export setting which will facilitate the export.
2D File Format
If the message was displayed when using the File>Export Tool, expand the 'General Tools' folder and click (or expand) the 'Import / Export Settings' folder. Look for a suitable existing setting to modify. In this example, we will refer to 'General Export' within the 'Import / Export Settings' folder.
Simply right-click on the existing setting and pick Change from the context menu.
Enable the file format in question (in this example, the LVS (*.lvs) format)) and then click OK to update the setting:
If you can’t see a similarly-named setting, right-click on the whitespace and pick Add from the context menu:
Name the setting appropriately, enable the relevant file format, and then click OK to add a new setting.
Re-try the 2D Export and this time, you should have an available export setting which will facilitate the export.
Still Not Working
If the above solution has not resolved your problem, you may have found another cause of this error. Please create a support ticket and describe the issue you're having with as many details as you can.